eclipse中Syntax error, 'for each' statements are only available if source level is 1.5 or greater


在導入別人的項目的時候,提示報錯說jdk版本應該是1.5或者以上,但是我電腦上裝的是JDK1.8,eclipse中用的也是JDK1.8,所以應該修改項目所指定的默認JDK版本。


解決方法:


對準當前的項目右擊,Properties-->Java Compiler,看右邊的JDK Compliance設到多少,要勾選Enable project specific settings 才能設置JDK版本,然後將你的JDK版本設置為你本機所裝的JDK版本即可。

0 個評論

要回覆文章請先登錄註冊